Thursday 30th April, 2015

DataTables 1.10.7

DataTables 1.10.7 has now been released and is a recommended update for all developers working with DataTables 1.10.

I hadn't been planning to make this release until the end of May, but the release of jQuery 1.11.3 and 2.1.4 exposed a bug in DataTables that caused it to throw an error when performing a "smart" search. As DataTables as a jQuery plug-in it is only right that a quick release should be expected to fully support the latest versions of jQuery.

New features

Included in 1.10.7 are two new API methods, specifically for two new extensions that I am working on for DataTables, but more generally because they are very useful when working with the DataTables API:

  • any() - Simply lets you know if any results have been found in the result set - for example table.rows( '.important' ).any() will return true if rows are found with the class important and false otherwise.
  • i18n() - Internationalisation for plug-in authors. This method provides authors with the ability to use information from the language configuration object for their plug-ins. It also includes support for languages that use singular, plural, dual, etc forms.


Alongside the jQuery incompatibility fix, there are a number of other changes to address known issues. This includes preventing a crash in EI6/7 and removing redundant code in the CSS file. Please see the full release notes for details.


The latest version of DataTables is available on the DataTables CDN for immediate use, or download the files for local installation.



Thanks to everyone for their support and input into the project. Bug reports, feature suggestions, hearing about how you are using DataTables and general encouragement are all very warmly welcomed.

I'm Looking forward to the next few months with the updates planned for the project!